How to install NetBeans on Mac

Version 1.0 (Aug 17, 2022)

The following should work on macOS versions 10.15 (Catalina), 11 (Big Sur) or 12 (Monterey). You can
check your OS version by clicking the Apple icon in the upper left corner of the screen (@), then clicking
‘About this Mac'.

For CIS/CSC-5, we suggest installing NetBeans version 12 or above, as described below. However, version
8.2 is sufficient for this course, if the following does not work?.

1. Install Xcode?
To compile C/C++ code, you need to install a compiler. Xcode is a set of programming
tools, compilers, and IDE that works natively on the Mac platform. It includes a C/C++
compiler.

Search for ‘xcode’ in the App Store and install it.
It is fairly large, so it may take some time to install.

After Xcode is installed, open it. If you see a window about a license agreement, make sure to click
‘Agree’:

Xcode and iOS SDK License Agreement

You must agree to both license agreements below in order to complete
the installation and use Xcode. By clicking Agree, you are agreeing to
the terms of the software license agreements.

Apple Inc.

Xcode and Apple SDKs Agreement

PLEASE SCROLL DOWN AND READ ALL OF THE FOLLOWING TERMS
AND CONDITIONS CAREFULLY BEFORE USING THE APPLE
SOFTWARE OR APPLE SERVICES. THIS IS A LEGAL AGREEMENT
BETWEEN YOU AND APPLE. IF YOU AGREE TO BE BOUND BY ALL
OF THE TERMS AND CONDITIONS, CLICK THE “AGREE” BUTTON. BY
CLICKING “AGREE” OR BY DOWNLOADING, USING OR COPYING ANY
PART OF THIS APPLE SOFTWARE OR USING ANY PART OF THE
APPLE SERVICES, YOU ARE AGREEING ON YOUR OWN BEHALF AND/

Save... Disagree Agree

Once you see the ‘Welcome to Xcode’ splash screen, you can close Xcode (click the Xcode menu,
then ‘Quit Xcode’).

! There are alternative methods of installing NetBeans that you may find easier, depending on your comfort level with macOS.
For example, see the ‘Installing NetBeans With Homebrew’ section.

2 Another method that doesn’t require installing all of Xcode is described in the section under Troubleshooting called ‘If Xcode
won't install or takes up too much disk space...’.
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2. Download NetBeans
Open the page: https://netbeans.apache.org/download/index.html
in a web browser and select a version of NetBeans to download.
NetBeans 14 is currently the suggested version, but slightly older versions (12, 12.4,
etc.) should also work:

OApacheNetBeans Community  Participate  Blog  Get

Latest release

Apache NetBeans 14

Download

Apache NetBeans Releases

Apache NetBeans is released four times a year. For details, see full release schedule.

Apache NetBeans 14

Lat ion of the IDE, released on June 9, 2022.

Older releases

Make sure to select the appropriate file to download for Mac. The file name should end with ‘.dmg’.

3. Install NetBeans
The downloaded NetBeans file should be in your Downloads folder. Open a Finder window and
navigate to Downloads.
Double-click on the file to install it.

< Downloads =¢ %0 v @) v Q
Favorites Name Size

D t
oeuments - 1-52.0-50031938417301919-main.pdf

5
Desktop @: 11_33680nys110618_69_79.docx 4
= Modeling_and_Simulation_of_Temperature_and_Relativ.pdf g

2

Recents
= Screen Shot 2020-09-10 at 2.03.38 PM.png
(.. Downloads < Quiz_1.pdf
AirDrop = Capture(1).PNG
= Gaddis_Chp3_Prob1_Flowchart.pdf
Dropbox . g
= Untitled Diagram-1.pdf
ownCloud I dcss-0.25.1-macos-console.zip 1C
Applicati... Bz 2.2 The Gamma Distribution.doc
libffi-3.1-26.fc33.src.rpm 9
Macintos... 2 Apache-NetBeans-12.2-bin-macosx.dmg 397
iCloud
iCloud Dri... 1:_' Macintosh HD > @ U > @@ jb > @ Downloads > & Apache-NetBeans-12.2-bin-macosx.dmg

1 of 148 selected, 204.93 GB available
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4. Configure NetBeans for C/C++
By default, NetBeans is not able to work with C/C++ projects®. A plugin needs to be installed to
enable it to work with the C/C++ tools available from Xcode.

Open NetBeans and go to the Tools menu, then select ‘Plugins’. In the Plugins window, click the
‘Settings’ tab. Activate the ‘NetBeans 8.2 Plugin Portal’ by checking the box next to it.

[ [ ) Plugins

Updates  Available Plugins (31)  Downloaded Installed (11)  Settings

Configuration of Update Centers:

Active Name N i ;
> NetBeans 8.2 Plugin Portal Edit Remove
— @ NetBeans 8.2 Plugin Portal
4 J NetBeans Distribution Last Check: never

v {fi# NetBeans Plugin Portal URL:
) (J Third Party Libraries http://updates.netbeans.org/netbeans/updat .2/uc/final/distribution/catal

Add
Automatically Check for Updates
Check Interval: Every Week v Proxy Settings
Advanced
Plugin Install Location: = Default v
Close Help

Now go to the ‘Available Plugins’ tab in the Plugins window. Click the ‘Check for Newest’ button. If
there is an entry for ‘C/C++’, check the box next to it and install it*.

[ [ ) Plugins

Updates (1)  Available Plugins (40) Downloaded  Installed (11)  Settings

@ Update an issue
® Create queries
® Find issues

& Qrhadilae

Check for Newest Search:
Install N: Cat Sol N
J nstal lame ategory gme e
Backlog Support Base IDE 7]
N GitHub Issues Support Base IDE ] (i Community Contributed Plugin
— C/C++ C/C++ L]
- iVi Update Center JDK-11 com.raelity.jvi iy Version: 0'9j° .
PHP Version Switcher com.vitexsof 7] Author: Junichi Yamamoto
) . oo Date: 6/21/20
Color Codes Preview Editing it Source: NetBeans Plugin Portal
nb-noext-mime-resolver Editing [} H https://github.com/junichi11/netbeans-backlog-plugin
Change Line Endings on Save Editing 7]
Close Editor Tabs Left and ... Editing 'im Plugin Description
Rainbow Braces Editing 77
No Newline Resolver Editing & This plugin provides support for backlog.
Extemal Code Formatters Editing e Features
textlint Support Editing (773
NB PojoMaker 0.4.3 io.github.ran... 7] ® Add an issue
i
e
]

Perforce io.github.trist...
nb-externalcommands io.github.trist...
sonarlint4netbeans Java

Install 1 plugin selected, 19MB

Close Help

3 In case you’re wondering, NetBeans by default is configured for Java development. However, it has plugins for other
programming languages, such as C/C++.
4 Click through the pop-up installation window’s ‘Next’ buttons, and be sure to check the ‘accept license agreement’ checkbox.
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Make sure the C/C++ plugin installs successfully. If it fails, the cause might be that the version of the
Java JDK on your system is not compatible with NetBeans. See the Troubleshooting section for a
possible fix.

Close the Plugins window.

5. Test NetBeans
Several things can go wrong when installing and configuring NetBeans, so it is necessary to check
that it is working properly.

Open NetBeans and click on the ‘New Project’ icon in the upper left corner of the NetBeans window
(E). An alternative way to open a new project is to click the ‘File’ menu, then ‘New Project...”. The
New Project window will open. Check that ‘C/C++" appears as an option in the ‘Categories’ list:

o ® New Project
Steps Choose Project
1. Choose Project Q) Filter:
Categories: Projects:
Java with Maven C/C++ Project with Existing Sources
Java with Gradle C/C++ Project from Binary Files
) [[7] C/C++ Application
Java with Ant ) [l C/C++ Dynamic Library
HTML5/JavaScript [[§ C/C++ Static Library

PHP GX C/C++ Qt Application

— ST (o 0Dy Loy
Samples C/C++ Qt Static Library

[ZJ Lightweight C/C++ Project

Description:

Creates a new project that uses an existing makefile or configure script and
existing sources. It uses your makefile to build the project.

Back Finish Cancel Help

If you do not see ‘C/C++ in the ‘Categories’ list — or you see it, but the only type listed in the
‘Projects’ list is ‘Lightweight C/C++ Project’, see the Troubleshooting section about this issue.

Otherwise, if ‘C/C++ is in the ‘Categories’ list and ‘C/C++ Application’ is one of the options under
the ‘Projects’ list, create a simple ‘hello world’ program to test NetBeans.

Ask a CIS/CSC lab aide or your instructor if you need help doing this.

Finally, if you’re able to compile and run your ‘hello world’ program, you have successfully installed
NetBeans!

C < — o D
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Installing NetBeans With Homebrew

If you have already installed NetBeans, don’t do this section!
This is just an alternative way that some might find easier than the method given above. It requires
installing Homebrew, as explained in Step 2 below.

1. Install Xcode
Use the same method described in Step 1 on Page 1.

2. Install Homebrew (if it’s not already installed)
Homebrew is a package manager for Mac®. If it is already installed on your system, you can skip this
step. If you’re not sure, we'll check for it here.

a. First, open a terminal window by going to the Go menu, selecting Utilities, then double-
clicking the Terminal app.

b. Inthe window that opens, type:
brew -v

and press <return>. If you then see some text talking about Homebrew in the window, you
already have it installed. If so, skip to Step 3.
Otherwise, if something like “command not found” comes up, it will need to be installed.

c. Paste the following line into the terminal window®:
/bin/bash -c "$(curl -fsSL
https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

and press <return>.
d. Follow the script’s prompts to install Homebrew.

3. Once Homebrew is installed, in the terminal window, simply type
brew install netbeans

and press <return>.
Homebrew should then set up NetBeans and its dependencies.

4. You will still need to configure NetBeans for C/C++, as described in Step 4 on page 3. You should
then continue with the next step (5), and test a simple ‘hello world’ program.

C < — o D

5 Besides installing NetBeans, you might find it handy for installing other software as well!
6 Or you can go to Homebrew’s website, https://brew.sh/, and follow instructions there (which are essentially the same as here).
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Troubleshooting

How to install NetBeans on Mac.v1.0.docx

If Xcode won't install or takes up too much disk space... S
You may be able to install just the C++ compiler and not all of Xcode.

Open a terminal window (Go menu -> Utilities -> Terminal).

Type ‘g++’ and press <return>. If a window pops up asking if you want to install the
command line developer tools, click ‘Install’.

If NetBeans installed, but you can’t create a C/C++ project...

For example:

You click the ‘New Project’ in NetBeans and nothing happens, OR

In the New Project window, you do not see a ‘C/C++ entry in the ‘Categories’ list, OR

In the New Project window you only see ‘Lightweight C/C++ Project’, in the ‘Projects’ list (when
‘C/C++ is selected in the ‘Categories’ list), try the following:

o Check if a C/C++ compiler is installed on your computer.

If you haven’t already, try installing Xcode, as described in Step 1. Make sure to run Xcode
after installation and ‘agree’ to any license agreement that pops up.

You can check if the compiler is installed by opening a terminal window S
(Go menu -> Utilities -> Terminal).

In the terminal window, type ‘g++ --version’ and press <return>. If
information about the C++ compiler appears in the window, the compiler is
installed.

Jemm— sh — 66x20

sh-3.2%$ g++ --version |
Configured with: --prefix=/Applications/Xcode.app/Contents/Develop
er/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Dev
eloper/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/inc
lude/c++/4.2.1

Apple clang version 12.0.0 (clang-1200.0.32.28)

Target: x86_64-apple-darwin20.2.0

Thread model: posix

InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchain
s/XcodeDefault.xctoolchain/usr/bin

sh-3.2%

However, if the returned message says something like ‘No such file or directory’,
the compiler is not installed, or is not configured correctly. You might try reinstalling Xcode,
if this is the case.

You may also try ‘c++ --version’ or ‘clang --version’ in the terminal window, as
these are other C++ compiler names.



o Check that the NetBeans 8.2 plugin is installed.
If you have already followed the instructions in Step 4 for configuring NetBeans for C/C++,
double-check the following:
= Check that the ‘NetBeans 8.2 Plugin Portal’ has been checked in
Tools -> Plugins -> Settings.

= |n Tools -> Plugins -> Available Plugins, if there is a ‘C/C++’ entry, make sure it is
checked/activated.

If you do check/activate the ‘C/C++’ entry, make sure it says it installed successfully.

If an error is reported instead, there could be a conflict with the installed version of
Java — see below for what to do next.

= Make sure you have restarted NetBeans.

= |f the problem persists, it’s possibly and issue with NetBeans and Java versions
conflicting. See below.

o There might be a conflict with the Java version and NetBeans.
For example, NetBeans 12 may not work with Java 14 or above. See
https://stackoverflow.com/questions/63954870/does-apache-netbeans-12-1-support-jdk-
15. If this is the suspected problem, it may be possible to install an older version of Java
and instruct NetBeans to use that version.
Details on how to do this are somewhat technical. Ask a CIS/CSC lab aide for assistance on
this.
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